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1.1  Introduction to SKSS
The Silent Knight Software Suite (SKSS) is a tool for communicating with IntelliKnight addressable fire 
panels, IFP-Series fire panels, SK-5208 fire panel, 5104B (UL 9th edition), and 5000-Series entry sys-
tems.The Silent Knight Software Suite (SKSS) is a tool for communicating with IntelliKnight addressable 
fire panels, SK-5208 fire panel, and 5000-Series entry systems.The Silent Knight Software Suite (SKSS) is 
a tool for communicating with IntelliKnight addressable fire panels, IFP-Series fire panels, and SK-5208 
fire panel. This software makes it is easy to program panels from a remote location, like the central station 
service center or locally when directly connected to the panel. SKSS allows you to upload (receive) data 
from a panel to a PC. For example, you can upload event history from a panel so that the history can be 
sorted and viewed on screen or printed as a report. You can also upload programming changes that have 
been made at the installation site to a PC.

1.1.1  Features
• Compatible with IntelliKnight 5820XL, 5808, 5700, 5104B (UL 9th Edition), IFP-1000, IFP-100, IFP-

50, and SK-5208 fire panels and 5000-Series entry systems.
• Easily program panels from a remote location or on-site
• Upload panel account information to your PC
• Quick access to panel event history
• Upload detector status from IntelliKnight and IFP-Series fire panels
• Forward and backward compatible with panel software
• Reduce the time it takes to reprogram an upgraded panel with the built-in Translate option
• Free software upgrades downloadable from the Silent Knight web site (www.silentknight.com)

1.1.2  About This Manual
This manual will help you get started using SKSS and is future reference for operations that you don’t fre-
quently perform. The menus and screens in the software are your main source of information for the more 
commonly performed operations. You can also get help from the software’s comprehensive Online help 
system by pressing the [F1] key at any time. For information on general concepts such as, mapping and 
points, that appear in SKSS programming views, refer to the panel’s Installation and Operations Manual.

1.1.3  System Requirements
To operate SKSS software you must have a PC with the following minimum requirements:

Windows® 98, 2000, 7, 8.1, 10, ME, NT®, XP, or Vista

64 megabytes RAM

32 megabytes of free hard disk space

VGA color or compatible monitor

A Bell 212A/103 Hayes® compatible Plug and Play modem to connect to remote panels. 

You can also connect directly to all compatible FACPs using a 9-pin serial cable or connect directly to 
5820XL, 5808, IFP-1000, and IFP-100 using an AB male USB cable.

1.1.4  Mouse Versus Keyboard
SKSS is designed to be used with a mouse. Using a mouse is the fastest and easiest way to operate the soft-
ware. However, a mouse is not a requirement; all operations can be performed from the keyboard. See your 
Windows documentation for information on navigating in a Windows environment.
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1.1.5  Online Help
You can press the [F1] key when you have SKSS running to bring up the online help system (not available 
during beta testing). The help screens describe each data entry area on the view and explain how to select 
options.

1.1.6  Backing Up Your Data
Protect your valuable data by frequently backing up files using the backup tool of your choice. Files with 
extensions.[Panel Type]Account, .[Panel Type]History and .[Panel Type]Detector contain your data. For 
example, a file with the extension .5820Account contains the account information on a 5820XL panel and 
a file with the extension .5808History contains the history information from a 5808 panel. Back up these 
files whenever you make changes. (See Table 1 on page 10 for more information about types of files and 
extensions.).

1.1.7  Technical Support
Silent Knight provides 7/24 technical support from our Web site at www.silentknight.com. Print installa-
tion and operations manuals, get answers to frequently asked questions, download the latest software revi-
sions, e-mail questions to technical support are just a few of the things you can do on our Web site. Silent 
Knight also offers free technical support.

How to Reach Us

Web site: 

www.silentknight.com

Technical support:

Monday - Friday, 8:00 AM to 5:00 PM CST

800-446-6444

1.2  Installing SKSS
SKSS walks you through the installation process and can be installed and configured to work with Silent 
Knight control panels in less than ten minutes.

1.2.1  Installing the Hardware Key for IFP-Series Panels
Depending on the SKSS version you ordered, you received a USB or parallel hardware key and manual. 
SKSS should be downloaded from internet at www.farenhyt.com. You must connect the hardware key to 
your PC prior to installing and running SKSS with IFP-series panels. Plug the hardware key into the appro-
priate port on your computer. If you have a parallel hardware key plug it into LPT1. If a printer is already 
connected LPT1, remove the printer cable, insert the hardware key into the port, then attach the printer 
cable to the hardware key as shown in the figure below.   

Figure 1.1  : Hardware Key Installation
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1.2.2  Installing SKSS
If you are a new user of Silent Knight software, go to the installation procedure below. If you have a ver-
sion of Silent Knight’s SK Analog Fire System Editor installed on your PC, the new software will not over-
write the directory or accounts you’ve already set up. Once you’ve installed SKSS, upload information 
from each panel to populate the software with your existing accounts. The files created in SK Analog Fire 
System Editor are not compatible with SKSS. For assistance with SK Analog Fire System Editor files, call 
Silent Knight Technical Support.

1.2.3  To install SKSS:
1. Download the SKSS at http://esd.farenhyt.com/esd/products/5650.htm

NOTE:Note: The CD Key is located on the inside of this manual’s the front cover.

2. Follow the instructions on the screen to continue installation. If an error occurs during installation, make 
sure you have sufficient memory and on your PC (see page 1). If you have sufficient system resources 
and the software still will not install or run, contact Silent Knight Technical Support at 800-446-6444.

1.2.4  Starting SKSS

NOTE: The IFP-Series panels require that a hardware key be installed before running the 
software.

To start SKSS:

1. From Start, select Programs, Silent Knight and then click on Silent Knight Software Suite. The login 
dialog box appears.

2. When logging on for the first time, select Master from the User Name dropdown list.
3. Press Tab to move to the Password text box and enter pass.
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4. Click OK. The SKSS window appears.
Note: If you’ve used the SK Analog Fire System Editor, note that the Communications Queue is no 
longer a separate application. The Communications Queue is integrated into SKSS as shown below.

1.2.5  Using Password Protection
Through the password system, you can make sure that only qualified users have access to SKSS. Or, if you 
prefer, you can disable password protection so that anyone in your facility can have access to SKSS.

Initial Password

SKSS comes with a Master User and Password. When logging on for the first time, select Master for the 
user and enter pass as the password. You can then change the password, add new users or disable password 
protection. 

Adding/Editing/Deleting Users and Passwords

You can add up to 100 users to SKSS, in addition to the Master User. All users can perform all software 
operations. The Master User cannot be deleted.

To add a user:
1. From the Options menu, select Users & Passwords. 

2. From the Users and passwords dialog box, click on Add User.
3. Enter up to 20 alphanumeric characters for the user and 20 

alphanumeric characters for the user’s password.
4. Click OK.

To delete a user: 

1. From the Options menu, select Users & Passwords. 

2. At the dialog box that displays, select the user you want to 
delete, then select Delete User.

3. Click OK. The user will be deleted.



151239

5

Turning Password Protection On/Off

If you don’t want to require users to enter passwords when they operate 
the software, you can permanently disable the dialog box for entering a 
password.

1. From the Options menu, select Users & Passwords. 

2. From the Users and passwords dialog box, click on the Enable login 
dialog box check box to turn protection on or off. If there is a check 
mark in the box password protection is on. If there is no check mark 
in the box, password protection is off.

1.2.6  Setting Up Communications with the Panel
Before you can use SKSS to communicate with a panel, you must configure a communication device. To 
connect to a remote panel, you’ll need to use your PC’s modem. To connect directly to an FACP, you can 
use a serial cable, or with 5820XL, 5808, IFP-1000, and IFP-100 panels you can use a USB cable.

PC Modem Connection

To communicate remotely with a panel, you will need to have a Hayes® compatible modem installed on your PC. Fol-
low the instructions in your PC and modem manuals for connecting a modem to your PC.

Serial & USB Cable Direct Connection to the FACPs

To communicate locally with a panel, you can connect a 9-pin serial cable to the FACP serial port or an AB 
male USB cable to the USB port (on all FACPs except the 5700 and the IFP-50). See the figure below.

NOTE:Note: The panel will go into ground fault trouble if you are connected to a PC powered by 
AC while the cable is connected. The trouble will clear when you disconnect the serial cable.   

Figure 1.2  : Direct Connection Ports on Silent Knight FACPs.

Configuring Communications Between the PC and Panel

To communicate with the panel, you will need to select the PC’s modem or if connecting directly to the 
panel with a serial or USB cable, select the com port to which the cable is connected.

To configure the communications device:

Click here 
to disable 
password 
protection.
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1. Select Options from the menu, then Communications.

2. Select the PC’s installed modem for modem communications or the com port to which the serial or USB 
cable is connected for direct connection to a FACP from the Line/Port drop-down list.

NOTE:Note: When communicating with some panels, communications speed is improved by 
adding the S10=255 AT command. SKSS will automatically check to see that the S10=255 AT 
command is set in the Windows Advanced Connections Setting of your modem when dialing 
certain panels. If not, SKSS will attempt to send the command. To configure the modem with this 
command, see the following paragraph.

Adding/Removing the S10=255 AT Command Setting

The S10=255 AT command ensures the most efficient operation for modem to panel communications. This 
command will improve communications reliability between the modem and compatible Silent Knight fire 
panels. 

The S10=255 setting may not be useful for other communications applications. During these times you can 
disable the S10=255 AT command. The next time you use SKSS, you will be reminded that the S10=255 
command is not set.

To add the S10=255 AT Command Setting:
1. Click on Configure Line in the Communication Configuration dialog box.
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2. Click on the Connection tab, then Advanced from the modem settings dialog box.

3. Type S10=255 in the Extra settings text box.

To remove the S10=255 AT Command Setting:
1. Click on the Windows Start button, then Settings, and finally Control Panel.

2. Double click on Modems. The Modems Properties dialog box appears.
3. Select the modem from the modem list and click on Properties.
4. Click on the Connection tab, then Advanced.
5. Delete S10=255 in the Extra settings text box and click OK.

1.2.7  SKSS File Types and Naming Conventions
SKSS has three file types. Each file type stores different information about a specific panel or account. File 
types are identified by their file extension as shown in the table below. When you are working with the 
files, a unique icon will display in the upper left corner.

Table 1.1  Types of Files

Icon File Type Contains Extension Panels

Account Views for 
programming a 
panel and other 
account 
information.

.[Panel 
No.]Account

All

Event 
History

Events that 
occurred at the 
panel. This file 
type is uploaded 
from the panel.

.[Panel 
No.]History

All

Detector 
Status

Status of 
detectors. This file 
type is uploaded 
from the panel.

.[Panel 
No.]Detector

5820XL, 
5808, and all 
IFP-Series
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1.2.8  File Menu
The file menu contains options that apply to all Windows applications (such as Open, Save, and Save As), 
as well as some options that are unique to SKSS. The chart below describes SKSS specific options.

Table 1.2  File Menu Options

Option Description

New Select New to create a new account file for uploading and/or downloading panel 
programming information.

Open 
Account

Open an account file that is already stored on the PC.

Open Event 
History

Open an event history file that has been uploaded from a panel to the PC.

Open 
Detector 
Status

Open a detector status file that has been uploaded from a panel. This option is for 
5820XL and IFP-1000 Rev. 1.2 and later, 5808, 5700, IFP-100, and IFP-50 panels.

Translate When there is more than one version of panel software, you can use the Translate 
feature to save programming time when upgrading a panel to a newer version of 
software. The new (translated) version of the account provides access to new 
programming options and previous programming will not be overwritten when you 
configure the new options.
When you open an account, the Panel version number appears on the Account Info 
view. The translate option is available only if the account is not already saved in the 
latest version. if you create a new account or open an account that is already in the 
latest version, the Translate option will be dimmed on the menu.
1. From the File Menu, select Translate. 

2. Click on OK in the Message Translated dialog box.
3. Save the account or use the Save As to save the old and new file.

Upload 
Account

Upload an account from a panel. (Data stored at the panel is sent to the PC.)

Download 
Account

Download an account to a panel. (Data store on the PC is sent to the panel.)

Upload Event 
History

Upload event history from IntelliKnight, IFP-Series, or SK-5208 panels to the PC. Once 
the event history has been uploaded it can be viewed on screen and printed.

Upload 
Detector 
Status

Upload detector status from IntelliKnight and IFP-Series panels to the PC.

Upload Clock You may never need to use this feature, but if you ever need to upload the clock setting 
from a FACP, this command allows you to do so. This feature is primarily for 
troubleshooting and verifying that the panel is operating properly. If the system clock 
should ever reset, you or Silent Knight technical support staff may want to know the 
current time at the panel. 

Download 
Clock

This feature synchronizes a FACP clock with the PC’s current time setting. This feature 
is only used for panels connected to via a modem.

Print You can print any of the file types from SKSS. When the file you want a report from is 
open, select Print from the File Menu. Prior to printing you can select Print Preview 
from the File menu to view the report on-screen.
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1.2.9  Programming
The programming views for the different panels are briefly discussed below. For complete information 
about the individual fields (or data entry areas), refer to the online help (not available in the beta version). 
For an overview of basic concepts about a panel refer to the panel’s Installation and Operations Manual.

Views for IntelliKnight and IFP-Series Panels

The figure below shows the General Parameters view, the view (or screen) for programming options that 
affect the general operation of the panel. Table 3 describes the purpose of each programming view for the 
FACPs.

Figure 1.3  : General Parameters View for Panel Programming.

Table 1.3  Programming Views for IntelliKnight and IFP-Series Panels

View Name Use This View To

Account Info. Program subscriber data, including account phone number, contact person name.

General 
Params.

Program options that affect general operation of the software, including system clock 
options.

Dialer Change options for the dialer. This includes such options as account number, reporting 
format, and other options related to reporting to a central station.

System Add and delete modules and select options for input and output points.

Input Zones Add, delete or modify options for input zones.

Output Groups Select options for output groups, including adding and deleting groups. 

Templates When an IntelliKnight or IFP-Series installation requires that zones be mapped to more 
than 8 output groups, you can use templates. With output group templates you can 
combine one or all output groups into one template, which can be used when the same 
combination of outputs are used for several zones.

Mapping Assign output groups to zones.
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1.2.10  Views for the SK-5208
The Zones screen below is one of several screens used to set programming options for the SK-5208.

Figure 1.4  : Zones View for Panel Programming

Output Pattern Create customized output patterns, patterns that sounding devices (or other output 
devices) will use.

User Profiles Create custom up to 20 users code with customized profiles for each user.

Table 1.4  Programming Views for the SK-5208

View Name Use This View To

Zones Add, delete or modify zones.

NAC/Relay Establish or modify zone NAC/output patterns such as silence, fire, prealarm, etc.

NAC/Output 
Patterns

Create custom output patterns for sounding devices and other output devices.

Dialer Change options for the dialer. This includes such options as account number, reporting 
format, and other options related to reporting to a central station.

Miscellaneous Add and modify 3 to 6 digit installer and operator user codes, alarm responses, such as 
NAC automatic silence time and prealarm time, and banner display settings.

Expander Select options for output groups, including adding and deleting groups. 

Table 1.3  Programming Views for IntelliKnight and IFP-Series Panels



151239

11

1.2.11  Views for the 5000-Series
The System screen is one of three screens used for the 5000-Series panels used to set general programming 
data, including system message, clock format and installer code.

1.3  Scheduling Jobs
The panel and a PC can communicate with each other by downloading (computer sends data to the panel) 
and uploading (panel sends data to the computer). This section of the manual describes communication 
operations.

Table 1.5  Programming Views for the 5000-Series

View Name Use This View To

System Set general programming data, such as the system message, clock format 
and installers code.

Users Program, edit and delete up to 1000 tenants. You can add user names in the 
SKSS, in addition to numbers. The user names are only stored in the SKSS 
and cannot be downloaded to the panel.

Aux. Relay Program and modify auxiliary relay settings.
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1.3.1  The Communications Queue 
The Queue is a list of completed and scheduled tasks between panels and SKSS. When a task appears in 
the Queue window, its status and other information will display next to the account number.

Figure 1.5  : Communications Queue Example

1.3.2  Delete Jobs from the Queue
All jobs remain in the queue until you delete them. You can delete jobs that are finished and jobs that are 
scheduled.

To delete a job from the Queue window:
1. Highlight the job you want to delete by clicking on it.

2. Press on the [Delete] key or right click to select from the menu that appears, then click Delete. This 
action cannot be undone.

1.3.3  Job Status
Jobs or accounts listed in the Queue window are assigned a status. The chart below describes all possible 
status types.

Table 1.6  Queue Job Status

Status Description

Waiting The job is waiting for processing. Another job is currently being processed or the job 
is timed to execute at a later time.

Error An error occurred during processing. No data was transferred. See Troubleshooting 
Communication Problems  for more information.

Processing The job is currently processing, for example, sending or receiving data.

Complete The job has completed successfully. Completed jobs remain on the queue until an 
operator deletes them.

Aborted by 
User

The job was cancelled during processing by an operator. Aborted by User jobs 
remain on the queue until an operator deletes them.

Timed Out The job was not completed because communication was not established during the 
programmed timeframe.
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1.4  Downloading and Uploading
You can download and upload various options, depending on the panel you are working with, such as panel 
programming settings and event history as shown in Table 7. When downloading, you are sending data 
(options that have been programmed using the SKSS programming views) to the panel. When uploading, 
you are sending data from the panel to the computer.   

Security Not 
Granted

The panel did not answer the call because an incorrect password was used by the 
operator who attempted to process the call.

No Carrier or
No Dial-tone

The job was not processed because communication was not established. This 
message can indicate several problems. See Communication Error Messages  for 
more information.

Modem Error The job was not processed because the software detected a problem with the 
modem. This message could indicate that modem is not turned on, needs to be 
initialized, or another problem. See Troubleshooting Communication Problems  for 
more information.

Busy Signal The job was not processed because the communication device encountered a busy 
signal when attempting to call.

No Answer The job was not processed because the initiating communication device did not 
receive an ACK signal.

Detector 
Status Not 
Supported

The detector status feature is not available for Rev. 1.1 panels; Revision 1.2 and 
later support the feature. If you attempt to run the Upload Detector Status feature on 
a Rev. 1.1 5820XL or IFP-1000 panel, you will receive this message.

Table 1.7  Download and Upload Options by Panel
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* The option for uploading detector status that appears on the file menu is available for Rev. 1.2 and later panels only.

To download or upload panel information:
1. From the File Menu, select the download or upload menu item you want to schedule. 

2. In the appropriate locations in the dialog box, enter your selections for the following options:
File Name: To download, select the file that you want to download. To upload assign a name to the file 

that will be uploaded from the panel. You can use the Browse option to select from the list of 
available files. If you do not select a name for the file, it will be automatically named with the 
panel model and the date and time of the download.
For downloads, the latest saved version of the file will be sent. This means if the file you want 
to send is currently open and has been changed, save it before you attempt to download. 

Account Number: Enter the panel account number. 
The default value for each control panel is listed in the installation manual for that control 
panels. The box remains blank for a 5000-Series panel.

Computer Code: Enter the code that allows access to the panel from a PC. The default value for each control 
panel is listed in the installation manual for that control panels.

Phone Number: If you are using a modem for communication, enter the panel phone number.
Call Option: Select how often and when the call should be placed.
Answering: Select the preferred options if the phone line used by the PC’s modem has an answering 

machine installed. This feature is not used when connecting directly to a panel.

3. Click OK to begin downloading/uploading or to post the job to the Queue.

Working with Event History Data

You can upload event history from IntelliKnight, IFP-Series, and SK-5208 panels. When uploading a file 
from the panel’s event history buffer, you will have all of the most recent events that have occurred at the 
panel. Not all the events may be of interest to you at any given time. You can use the software to select 
only events that meet particular criteria, sort events, print and combine files of events. 

Note: The 5000-Series panels do not store events, so this procedure does not apply to the 
5000-Series panels.

1. Once event history has been uploaded, select Open History from the File Menu.

Option IntelliKnight IFP-Series SK-5208 5000-Series

Panel 
Programming

• • • •

Event History • • •

Clock Settings • • •

Detector Status* • •
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2. Select a file to open. You can scroll through the list of available files or enter the file name in the File 
Name area in the dialog box.

3. From the next dialog box that displays, select options for controlling how the history is displayed on 
screen and printed. Refer to the online help for more details about these options (not available during 
beta testing). If you want a printed report of the data, select Print from the File Menu.

Figure 1.6  : Event History Window.

Combining Event History Files (Append History)

The IntelliKnight and IFP-Series panels can store up to 1000 events and SK-5208 panels can store up to 
150 events. When a panel reaches its 1000 event capacity, it begins deleting events starting with the oldest. 
When you save an upload, you create a file that you can save permanently or for as long as you need it. 
You can also append (or add) events from another file so that uploaded event files will be combined, saving 
you from having to search through multiple files. 

For example, suppose a panel reported 1000 events every two weeks, but you wanted to retain files of 
events by month. Since the panel would start deleting events as more were added, the panel’s buffer would 
never contain an entire month of data. You could compensate for this by uploading event history twice per 
month, once for the first half of the month and once for the second half. You could then Append the events 
from the second half of the month to the file for the first month. Your file would then contain events for an 
entire month. 

To add history events from one file to another:
1. Open the primary history file by selecting Open Event History from the File Menu.

2. With a history file open, click on Append History File.
3. Select the file that you want to add to the primary history file. You can scroll through the list of available 

files or enter the file name in the File Name area in the dialog box. Event history files have the 
extension [Panel Type] History.

4. The file now contains event data from both files. When you save the file, you may want to use the Save 
As feature to give the combined file a unique name.

Select order in
which events

Display events 
that occurred 

Select the 
types of events 
to display
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1.5  Detector Status Data
When you upload detector status from an IntelliKnight or IFP-Series panel, you will have a file containing 
the status of all detectors in the system. Not all the detectors may be of interest to you at any given time. 
You can use SKSS to select only detectors that meet particular criteria, such as, detectors that are out of 
compliance or that need maintenance. You can also sort the file by various criteria and print the informa-
tion that you need. 

1. Once detector status has been uploaded, select Open Detector Status from the File Menu.

2. Select a file to open. You can scroll through the list of available files or enter the file name in the File 
Name area in the dialog box. Detector status files have the extension:
 .[Panel Type] Detector.

3. The Detector Status View will display. Select options for controlling how the detector status is displayed 
on screen and printed. A dialog box similar to the one below will display. Refer to the options on the 
help screen for complete information about how to select these options. If you want a printed report of 
the data, select Print from the File Menu. 

Figure 1.7  : Detector Status Dialog Box

1.6  Communication Error Messages
The chart below describes communication error messages that could occur during processing. These mes-
sages indicate that transfer of data did not occur. If you receive one of these messages and do not know 
what caused it, see Troubleshooting Communications problems below. If the problem persists, contact 
Silent Knight Technical Support at 800-446-6444.

Table 1.8  Communication Error Messages

Message Explanation

Error An error occurred during processing of the call. No data was transferred. This message can 
indicate a wide variety of problems, including a problem with the modem or noise on the 
telephone lines.
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1.6.1  Troubleshooting Communication Problems
Troubleshooting communication problems can be complex because the problem could be at either end of 
the connection. If communication did not occur or was incomplete, here are some things to try.

When using a modem, make sure the communication device is connected to the phone line and that dial 
tone is present. If you suspect that noise on the telephone line is causing a problem, try any or all of the fol-
lowing:

• Hang up and try again.
• Initialize hardware. This will happen any time you close the queue and reopen it. You may need to reset 

the modem, especially if you receive the “Modem Error” message.

Timed Out The job was not completed because communication was not established during the 
programmed time frame.

No Carrier The job was not completed because the communication device could not establish 
communication.

Modem Error The job was not completed because the software detected a problem with the modem. Make 
sure the modem is turned on. Try reinitializing the modem.

Busy Signal The communication device encountered a busy signal when attempting to communication. 
Try again later.

No Answer The communication device did not receive an ACK signal. 

No Dial-tone A dial-tone could not be detected by the communication device. Check that the receiving 
device is turned on and is connected to the phone line.

Table 1.8  Communication Error Messages
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